$re = '/<div[^>]*>((?:(?:(?!<div[^>]*>|<\/div>).)+|<div[^>]*>(?1)<\/div>)*)<\/div>/is';
$str = '<div class="cls1">
Hello
<p></p>
<div id="id1">
Hi mohammad
</div>
<div></div>
</div>
<div class="cls1">
Hello
<p></p>
<div id="id1">
Hi mohammad
</div>
<div></div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);