import Foundation
let pattern = #"(?'Year'[0-9]+)-(?'Month'0{0,1}[1-9]|10|11|12)-(?'Day'[0-2]{0,1}[1-9]|10|20|30|31)-(?'Hour'[01]{0,1}[0-9]|2[0-3])-(?'Minute'[0-5]{0,1}[0-9])-(?'Second'[0-5]{0,1}[0-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2015-12-05-23-59-59"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}