#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?'Year'[0-9]+)-(?'Month'0{0,1}[1-9]|10|11|12)-(?'Day'[0-2]{0,1}[1-9]|10|20|30|31)-(?'Hour'[01]{0,1}[0-9]|2[0-3])-(?'Minute'[0-5]{0,1}[0-9])-(?'Second'[0-5]{0,1}[0-9])"
Local $sString = "2015-12-05-23-59-59"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")