const regex = /(?'Year'[0-9]+)-(?'Month'0{0,1}[1-9]|10|11|12)-(?'Day'[0-2]{0,1}[1-9]|10|20|30|31)-(?'Hour'[01]{0,1}[0-9]|2[0-3])-(?'Minute'[0-5]{0,1}[0-9])-(?'Second'[0-5]{0,1}[0-9])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'Year\'[0-9]+)-(?\'Month\'0{0,1}[1-9]|10|11|12)-(?\'Day\'[0-2]{0,1}[1-9]|10|20|30|31)-(?\'Hour\'[01]{0,1}[0-9]|2[0-3])-(?\'Minute\'[0-5]{0,1}[0-9])-(?\'Second\'[0-5]{0,1}[0-9])', '')
const str = `2015-12-05-23-59-59`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}