$re = '/(?\'Year\'[0-9]+)-(?\'Month\'0{0,1}[1-9]|10|11|12)-(?\'Day\'[0-2]{0,1}[1-9]|10|20|30|31)-(?\'Hour\'[01]{0,1}[0-9]|2[0-3])-(?\'Minute\'[0-5]{0,1}[0-9])-(?\'Second\'[0-5]{0,1}[0-9])/';
$str = '2015-12-05-23-59-59';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);