// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?'Year'[0-9]+)-(?'Month'0{0,1}[1-9]|10|11|12)-(?'Day'[0-2]{0,1}[1-9]|10|20|30|31)-(?'Hour'[01]{0,1}[0-9]|2[0-3])-(?'Minute'[0-5]{0,1}[0-9])-(?'Second'[0-5]{0,1}[0-9])").unwrap();
let string = "2015-12-05-23-59-59";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}