// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"u'([^']+)': u'([^']+)'").unwrap();
let string = "dep14.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep24.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep21.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep23.cap1-infra.gsnetcloud.corp']\" id=\"4\" name=\"local_disks_host_aggregate\" properties=\"{u'cpu_allocation_ratio': u'1.0', u'disks.local': u'true', u'ram_allocation_ratio': u'1.0', u'ephem.ssd': u'false', u'disks.max': u'9'}\" updated_at=\"None\" region=CAP1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}