import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "u'([^']+)': u'([^']+)'";
final String string = "dep14.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep24.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep21.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep23.cap1-infra.gsnetcloud.corp']\" id=\"4\" name=\"local_disks_host_aggregate\" properties=\"{u'cpu_allocation_ratio': u'1.0', u'disks.local': u'true', u'ram_allocation_ratio': u'1.0', u'ephem.ssd': u'false', u'disks.max': u'9'}\" updated_at=\"None\" region=CAP1\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}