use strict;
my $str = 'dep14.cap1-infra.gsnetcloud.corp\', u\'srvcap101cnodep24.cap1-infra.gsnetcloud.corp\', u\'srvcap101cnodep21.cap1-infra.gsnetcloud.corp\', u\'srvcap101cnodep23.cap1-infra.gsnetcloud.corp\']" id="4" name="local_disks_host_aggregate" properties="{u\'cpu_allocation_ratio\': u\'1.0\', u\'disks.local\': u\'true\', u\'ram_allocation_ratio\': u\'1.0\', u\'ephem.ssd\': u\'false\', u\'disks.max\': u\'9\'}" updated_at="None" region=CAP1
';
my $regex = qr/u'([^']+)': u'([^']+)'/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}