using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"u'([^']+)': u'([^']+)'";
string input = @"dep14.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep24.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep21.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep23.cap1-infra.gsnetcloud.corp']"" id=""4"" name=""local_disks_host_aggregate"" properties=""{u'cpu_allocation_ratio': u'1.0', u'disks.local': u'true', u'ram_allocation_ratio': u'1.0', u'ephem.ssd': u'false', u'disks.max': u'9'}"" updated_at=""None"" region=CAP1
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}