#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "u'([^']+)': u'([^']+)'"
Local $sString = "dep14.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep24.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep21.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep23.cap1-infra.gsnetcloud.corp']" id="4" name="local_disks_host_aggregate" properties="{u'cpu_allocation_ratio': u'1.0', u'disks.local': u'true', u'ram_allocation_ratio': u'1.0', u'ephem.ssd': u'false', u'disks.max': u'9'}" updated_at="None" region=CAP1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")