re = /\/\/::\s?([^\r\n]+?)[\r\n]/
str = 'div
//:: Welcome to stuff!
h1=T[\'welcome\']'
# Print the match result
str.match(re) do |match|
puts match.to_s
end