using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\/::\s?([^\r\n]+?)[\r\n]";
string input = @"div
//:: Welcome to stuff!
h1=T['welcome']";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}