const regex = /\/\/::\s?([^\r\n]+?)[\r\n]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\\/::\\s?([^\\r\\n]+?)[\\r\\n]', '')
const str = `div
//:: Welcome to stuff!
h1=T['welcome']`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}