$re = '/\/\/::\s?([^\r\n]+?)[\r\n]/';
$str = 'div
//:: Welcome to stuff!
h1=T[\'welcome\']';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);