// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(!?.*\.(docx|pptx|xlsx|pdf|txt|zip))$").unwrap();
let string = "C:\\Temp\\file.docx
C:\\Temp\\file.jpg
D:\\Dir1\\Dir2\\hidden.txt
C:\\Another Dir\\temp\\file.doc
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}