using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(!?.*\.(docx|pptx|xlsx|pdf|txt|zip))$";
string input = @"C:\Temp\file.docx
C:\Temp\file.jpg
D:\Dir1\Dir2\hidden.txt
C:\Another Dir\temp\file.doc
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}