const regex = /^(!?.*\.(docx|pptx|xlsx|pdf|txt|zip))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(!?.*\\.(docx|pptx|xlsx|pdf|txt|zip))$', 'gm')
const str = `C:\\Temp\\file.docx
C:\\Temp\\file.jpg
D:\\Dir1\\Dir2\\hidden.txt
C:\\Another Dir\\temp\\file.doc
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}