package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(!?.*\.(docx|pptx|xlsx|pdf|txt|zip))$`)
var str = `C:\Temp\file.docx
C:\Temp\file.jpg
D:\Dir1\Dir2\hidden.txt
C:\Another Dir\temp\file.doc
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}