$re = '/^(!?.*\.(docx|pptx|xlsx|pdf|txt|zip))$/m';
$str = 'C:\\Temp\\file.docx
C:\\Temp\\file.jpg
D:\\Dir1\\Dir2\\hidden.txt
C:\\Another Dir\\temp\\file.doc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);