import Foundation
let pattern = #"([+\-]*[1-9][0-9]?[0-9]?(ne|nw|se|sw|n|s|e|w|NE|NW|SE|SW|N|S|E|W|Ne|Nw|Se|Sw|nE|nW|sE|sW))*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"1Nw-2sE7nE6Sw"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}