$re = '/([+\-]*[1-9][0-9]?[0-9]?(ne|nw|se|sw|n|s|e|w|NE|NW|SE|SW|N|S|E|W|Ne|Nw|Se|Sw|nE|nW|sE|sW))*/i';
$str = '1Nw-2sE7nE6Sw';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);