re = /([+\-]*[1-9][0-9]?[0-9]?(ne|nw|se|sw|n|s|e|w|NE|NW|SE|SW|N|S|E|W|Ne|Nw|Se|Sw|nE|nW|sE|sW))*/i
str = '1Nw-2sE7nE6Sw'
# Print the match result
str.match(re) do |match|
puts match.to_s
end