const regex = /([+\-]*[1-9][0-9]?[0-9]?(ne|nw|se|sw|n|s|e|w|NE|NW|SE|SW|N|S|E|W|Ne|Nw|Se|Sw|nE|nW|sE|sW))*/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+\\-]*[1-9][0-9]?[0-9]?(ne|nw|se|sw|n|s|e|w|NE|NW|SE|SW|N|S|E|W|Ne|Nw|Se|Sw|nE|nW|sE|sW))*', 'i')
const str = `1Nw-2sE7nE6Sw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}