import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([+\\-]*[1-9][0-9]?[0-9]?(ne|nw|se|sw|n|s|e|w|NE|NW|SE|SW|N|S|E|W|Ne|Nw|Se|Sw|nE|nW|sE|sW))*";
final String string = "1Nw-2sE7nE6Sw";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}