// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(\d+\$)(a*(\W))from(a*(\W))steam(?:\s*\n)*\s?\[(steamcommunity\.com\/gift\/[^\]]+)\]\((https?:\/\/[^\s]+\.[^\s]+)\)").unwrap();
let string = "50$ From steam
[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc)
200$ from steam
[steamcommunity.com/gift/8349393928202](http://another.link)
Random message 50$ From steam
[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc) @everyone";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}