package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(\d+\$)(a*(\W))from(a*(\W))steam(?:\s*\n)*\s?\[(steamcommunity\.com\/gift\/[^\]]+)\]\((https?:\/\/[^\s]+\.[^\s]+)\)`)
var str = `50$ From steam
[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc)
200$ from steam
[steamcommunity.com/gift/8349393928202](http://another.link)
Random message 50$ From steam
[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc) @everyone`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}