use strict;
my $str = '50$ From steam
[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc)
200$ from steam
[steamcommunity.com/gift/8349393928202](http://another.link)
Random message 50$ From steam
[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc) @everyone';
my $regex = qr/(?i)(\d+\$)(a*(\W))from(a*(\W))steam(?:\s*\n)*\s?\[(steamcommunity\.com\/gift\/[^\]]+)\]\((https?:\/\/[^\s]+\.[^\s]+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}