import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(\\d+\\$)(a*(\\W))from(a*(\\W))steam(?:\\s*\\n)*\\s?\\[(steamcommunity\\.com\\/gift\\/[^\\]]+)\\]\\((https?:\\/\\/[^\\s]+\\.[^\\s]+)\\)";
final String string = "50$ From steam\n"
+ "[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc)\n\n"
+ "200$ from steam\n"
+ "[steamcommunity.com/gift/8349393928202](http://another.link)\n\n"
+ "Random message 50$ From steam\n"
+ "[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc) @everyone";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}