$re = '/(?i)(\d+\$)(a*(\W))from(a*(\W))steam(?:\s*\n)*\s?\[(steamcommunity\.com\/gift\/[^\]]+)\]\((https?:\/\/[^\s]+\.[^\s]+)\)/m';
$str = '50$ From steam
[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc)
200$ from steam
[steamcommunity.com/gift/8349393928202](http://another.link)
Random message 50$ From steam
[steamcommunity.com/gift/8349393928202](https://scamlink.net/etc) @everyone';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);