// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"les-programmes\/[^\/]+\/.*$").unwrap();
let string = "/les-programmes/mon-premier-festival-2017
/les-programmes/les-incassables
/les-programmes/100-doc-colombie/nuestra-voz-de-tierra-memoria-y-futuro
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}