package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`les-programmes\/[^\/]+\/.*$`)
var str = `/les-programmes/mon-premier-festival-2017
/les-programmes/les-incassables
/les-programmes/100-doc-colombie/nuestra-voz-de-tierra-memoria-y-futuro
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}