re = /les-programmes\/[^\/]+\/.*$/
str = '/les-programmes/mon-premier-festival-2017
/les-programmes/les-incassables
/les-programmes/100-doc-colombie/nuestra-voz-de-tierra-memoria-y-futuro
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end