#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "les-programmes\/[^\/]+\/.*$"
Local $sString = "/les-programmes/mon-premier-festival-2017" & @CRLF & _
"/les-programmes/les-incassables" & @CRLF & _
"/les-programmes/100-doc-colombie/nuestra-voz-de-tierra-memoria-y-futuro" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")