import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "les-programmes\\/[^\\/]+\\/.*$";
final String string = "/les-programmes/mon-premier-festival-2017\n"
+ "/les-programmes/les-incassables\n"
+ "/les-programmes/100-doc-colombie/nuestra-voz-de-tierra-memoria-y-futuro\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}