re = /(\d*)( *)(x|\*)/m
str = '500 g (4 x 125 g)
1,8 kg (20 * 90 g)
380 g (2 x 190 g)
1,6 kg (16 x 100 g)
1,6 kg (226x100 g)
8 x 100 g
2 l'
subst = '$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result