# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d*)( *)(x|\*)"
test_str = ("500 g (4 x 125 g)\n"
"1,8 kg (20 * 90 g)\n"
"380 g (2 x 190 g)\n"
"1,6 kg (16 x 100 g)\n"
"1,6 kg (226x100 g)\n"
"8 x 100 g\n"
"2 l")
subst = "$0"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.