const regex = /(\d*)( *)(x|\*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*)( *)(x|\\*)', 'gm')
const str = `500 g (4 x 125 g)
1,8 kg (20 * 90 g)
380 g (2 x 190 g)
1,6 kg (16 x 100 g)
1,6 kg (226x100 g)
8 x 100 g
2 l`;
const subst = `$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);