using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*)( *)(x|\*)";
string substitution = @"$0";
string input = @"500 g (4 x 125 g)
1,8 kg (20 * 90 g)
380 g (2 x 190 g)
1,6 kg (16 x 100 g)
1,6 kg (226x100 g)
8 x 100 g
2 l";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}