import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d*)( *)(x|\\*)";
final String string = "500 g (4 x 125 g)\n"
+ "1,8 kg (20 * 90 g)\n"
+ "380 g (2 x 190 g)\n"
+ "1,6 kg (16 x 100 g)\n"
+ "1,6 kg (226x100 g)\n"
+ "8 x 100 g\n"
+ "2 l";
final String subst = "$0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}