import Foundation
let pattern = #"(?:(.*)\s+(&|\*)\s*const|(.*)(?:\s+)const(?:\s*)(&|\*)?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
std::string const&
std::string const
const std::string&
const char*
std::unordered_map<int, EnhancedGameObject*> const*
std::string * const
char const *
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"const \1\2\3\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)