$re = '/(?:(.*)\s+(&|\*)\s*const|(.*)(?:\s+)const(?:\s*)(&|\*)?)$/m';
$str = 'std::string const&
std::string const
const std::string&
const char*
std::unordered_map<int, EnhancedGameObject*> const*
std::string * const
char const *';
$subst = "const \1\2\3\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;