import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(.*)\\s+(&|\\*)\\s*const|(.*)(?:\\s+)const(?:\\s*)(&|\\*)?)$";
final String string = "std::string const&\n"
+ "std::string const\n"
+ "const std::string&\n"
+ "const char*\n"
+ "std::unordered_map<int, EnhancedGameObject*> const*\n"
+ "std::string * const\n"
+ "char const *";
final String subst = "const \\1\\2\\3\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}