#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(.*)\s+(&|\*)\s*const|(.*)(?:\s+)const(?:\s*)(&|\*)?)$"
Local $sString = "std::string const&" & @CRLF & _
"std::string const" & @CRLF & _
"const std::string&" & @CRLF & _
"const char*" & @CRLF & _
"std::unordered_map<int, EnhancedGameObject*> const*" & @CRLF & _
"std::string * const" & @CRLF & _
"char const *"
Local $sSubst = "const \1\2\3\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)