using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(.*)\s+(&|\*)\s*const|(.*)(?:\s+)const(?:\s*)(&|\*)?)$";
string substitution = @"const \1\2\3\4";
string input = @"std::string const&
std::string const
const std::string&
const char*
std::unordered_map<int, EnhancedGameObject*> const*
std::string * const
char const *";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}