import Foundation
let pattern = #"(?:\G|(LETTER))A"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"I am the letter LETTERAAAAAAAAAA like AAAlpha AAAAnd I will always be the first in LETTERAAAAAlphabet."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1B"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)