import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G|(LETTER))A";
final String string = "I am the letter LETTERAAAAAAAAAA like AAAlpha AAAAnd I will always be the first in LETTERAAAAAlphabet.";
final String subst = "$1B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}