re = /(?:\G|(LETTER))A/m
str = 'I am the letter LETTERAAAAAAAAAA like AAAlpha AAAAnd I will always be the first in LETTERAAAAAlphabet.'
subst = '$1B'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result