$re = '/(?:\G|(LETTER))A/m';
$str = 'I am the letter LETTERAAAAAAAAAA like AAAlpha AAAAnd I will always be the first in LETTERAAAAAlphabet.';
$subst = "$1B";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;