const regex = /(?:\G|(LETTER))A/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G|(LETTER))A', 'gm')
const str = `I am the letter LETTERAAAAAAAAAA like AAAlpha AAAAnd I will always be the first in LETTERAAAAAlphabet.`;
const subst = `$1B`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);